BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

openBVE 1.5.0 RC1 - BUGS

+29
HijauKuda
Manuel18
Delsin
Phonteus Nevolius
theflyingoreo
parker78
graymac
ebennekom
NakanoS
LabRatAndy
leezer3
jckhinks
Quork
call2
Stevegr
jorgecerezo
SysVR
BillEWS
buckysam
tof63
MattD6R
thehoviskid
phontanka
mobile1
Dj Hammers
Glory! koshikii
fas
Marc Riera
Dexter
33 posters

Page 18 of 21 Previous  1 ... 10 ... 17, 18, 19, 20, 21  Next

Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Tue Apr 02, 2019 11:51 am

Car object only.

That also begs the question of how to sensibly reverse the entire car, needs a new command I think.....
Marginally tempted to change to using ObjectReversed and Reversed, but that goes against the existing behaviour from extensions.cfg

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by Delsin Tue Apr 02, 2019 8:15 pm

BodyReversed (body only), Reversed (body only, left for compatibility and to be deprecated) and InvertHeading (completely with bogies) Very Happy

What I've spotted now:

  • cars with 21.5m between coupler faces and Length set to 21.5 still have a gap between them even with coupler distances set to 0
  • I haven't found a way to specify different distances for front and back couplers
Delsin
Delsin

Posts : 294
Join date : 2016-08-20

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Maybe its a bug

Post by Manuel18 Fri May 10, 2019 7:45 pm

Creating a train for OpenBVE. I realize the command timetable only works for internal objects "Panel.animated" and not for external objects included on extension.cfg

Why I do that?
Some trains in my case have a front destination table for ever. Don't need change with a special beacon (as destination command off course). So I just decide use that method and just found that exception

Per example.
My subway train run to Terminal Z. It's obviously he will make stops to A-Z on all these stations than contain A-Z interval.

In other words. Car0 will have half texture timetable showing Terminal Z. While last car will have Terminal A

Fixing that will be a benefit. In my case I had a external object than calls panel.animated. That avoid me to work on a special interior and even better a functional cab while I'm on exterior view

Thanks for reading
Regards
Manuel18
Manuel18

Posts : 74
Join date : 2012-10-18
Age : 27
Location : Caracas,Venezuela

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Wed May 15, 2019 12:59 pm

Manuel18 wrote:Creating a train for OpenBVE. I realize the command timetable only works for internal objects "Panel.animated" and not for external objects included on extension.cfg

Why I do that?
Some trains in my case have a front destination table for ever. Don't need change with a special beacon (as destination command off course). So I just decide use that method and just found that exception

Per example.
My subway train run to Terminal Z. It's obviously he will make stops to A-Z on all these stations than contain A-Z interval.

In other words. Car0 will have half texture timetable showing Terminal Z. While last car will have Terminal A

Fixing that will be a benefit. In my case I had a external object than calls panel.animated. That avoid me to work on a special interior and even better a functional cab while I'm on exterior view

Thanks for reading
Regards

Fixed for the latest build:
https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2019-05-16.zip

PLEASE NOTE:
The last few builds contain some very significant internal plumbing changes, combining the static (csv / b3d / x / obj) object loaders into shared plugins, along with various related work.
I don't believe that anything else has been broken in the process, but please be aware of this Smile


Last edited by leezer3 on Thu May 16, 2019 9:41 pm; edited 1 time in total

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by HijauKuda Thu May 16, 2019 4:11 pm

Sir leezer3
I did today download install your version of 2019-05-15.
Now I have popup error window "Unhandled exception: Value cannot be null. Parameter name: stream"
on start the main program and can not continue.
I prior did not error in your version 2019-04-09.
Good day and night for you
Hijau

HijauKuda

Posts : 102
Join date : 2012-01-18

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Thu May 16, 2019 9:44 pm

Sad

Now fixed, thanks-
https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2019-05-16.zip

Unfortunately, this is why it'd be really nice for more people to test the alpha builds- With only a couple of us working on the source, it's very difficult to test every combination, and this one was caused nearly a month ago.....

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by HijauKuda Fri May 17, 2019 2:55 am

Sir leezer3
I did now download install your fix version 2019-05-16.
I do not error and can continue now. It is good.
Good day and night for you
Hijau

HijauKuda

Posts : 102
Join date : 2012-01-18

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by Raffles Sun May 26, 2019 4:56 pm

Hi Leezer

I am on Linux Ubuntu 18.04 LTS. I have tried to install both openBVE-1.5.4.1 and openBVE-1.6.0.0 from the .deb files. They install OK but won't run. I have rolled back to openBVE-1.5.3.11 which runs OK.

The zip version of openBVE-1.6.0.0 works, but of course it is not installed in the correct directories, as I extracted it in the downloads folder and ran it from there with wine.

The log.txt for openBVE-1.6.0.0.deb is attached, as are 2 screen shots.

Cheers

Ralph

openBVE 1.5.0 RC1 - BUGS - Page 18 Screen10

openBVE 1.5.0 RC1 - BUGS - Page 18 Screen11


Last edited by Raffles on Sun May 26, 2019 4:59 pm; edited 1 time in total
Raffles
Raffles

Posts : 24
Join date : 2019-03-30

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by Raffles Sun May 26, 2019 5:02 pm

The log.txt file
Attachments
openBVE 1.5.0 RC1 - BUGS - Page 18 Attachment
log.txt You don't have permission to download attachments.(15 Kb) Downloaded 3 times
Raffles
Raffles

Posts : 24
Join date : 2019-03-30

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Sun May 26, 2019 9:06 pm

Thanks, I'm reasonably sure I know what's causing that one, and the root cause is a quirk of Mono.

I believe current nightly builds will work again, or alternatively install the latest Mono direct from themselves....

The log you're posting is from an older game session (which is also crashing- When GDI plus goes on Mono, it takes the entire runtime down. Whilst this is not our issue, I don't believe this is fixed either, I've got an open bug with Mono on this one here: https://github.com/mono/libgdiplus/issues/533 )

TLDR:
For reasons I'm not quite clear on (I did raise a bug with Mono on this a year or so back), in certain circumstances when the Mono compiler is upgraded, it can change the generated IL in a non-backwards compatible manner.
This is different to the MS compiler, which retains backwards compatibility.....
This caught us out once before with the Mac builds

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by Raffles Mon May 27, 2019 12:52 am

Thanks for the reply. I'm on the road for a month but I will check periodically and try out any new version that comes up. In any case, the version 1.5.3.11 works without a hitch. The bug you mention might be the cause of another non related program failing to load so it will be nice if the Mono devs can fix it.
Raffles
Raffles

Posts : 24
Join date : 2019-03-30

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by HijauKuda Fri Jun 07, 2019 3:32 pm

Sir leezer3
I did today download install your version of 2019-06-06.
Now I have the error of this crash log and popup return to the route and the train selector window
System.NullReferenceException: Object reference not set to an instance of an object.
at OpenBveApi.Textures.PathOrigin.GetTexture(Texture& texture)
at LibRender.TextureManager.LoadTexture(Texture handle, OpenGlTextureWrapMode wrap, Int32 currentTicks, InterpolationMode Interpolation, Int32 AnisotropicFilteringLevel)
at OpenBve.Host.LoadTexture(Texture Texture, OpenGlTextureWrapMode wrapMode)
at LibRender.Renderer.DrawRectangle(Texture texture, Point point, Size size, Nullable`1 color)
at OpenBve.Renderer.DrawLoadingScreen()
at OpenBve.OpenBVEGame.LoadingScreenLoop()
at OpenBve.OpenBVEGame.OnLoad(EventArgs e)
at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
at OpenBve.MainLoop.StartLoopEx(MainDialogResult result)
at OpenBve.Program.Main(String[] args) at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
at System.Environment.get_StackTrace()
at OpenBve.Program.Main(String[] args)

I prior did not error in your version 2019-05-16..
Good day and night for you
Hijau

HijauKuda

Posts : 102
Join date : 2012-01-18

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Fri Jun 07, 2019 6:23 pm

I cannot immediately reproduce that one.

Which route / train combination please?

(Note: There is a *lot* of internal plumbing work going on at the minute, so build breakages may be a little more frequent than usual Sad )

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Tue Jun 11, 2019 1:00 pm

OK, found and fixed Smile

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by mrknowitall Tue Jun 11, 2019 1:13 pm

leezer3 wrote:OK, found and fixed Smile


What was the issue?
mrknowitall
mrknowitall

Posts : 822
Join date : 2011-07-09
Age : 29
Location : W. Yorkshire

https://www.pioneertrains.co.uk/

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Tue Jun 11, 2019 1:31 pm

It's somewhat complex, but was related to the use of custom loading screens, and when the (new) shared renderer library was initialized.

In order to use a custom load screen, we need to (obviously) preload the texture, but at the time this was done, the renderer library hadn't been correctly initialized.
When we then attempted to draw this texture to the screen, it failed and crashed.

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by HijauKuda Wed Jun 12, 2019 11:52 am

Sir leezer3
I did now download install your fix version of the day 2019-06-11.
I do not crash the load button and continue now. It is good.

I do have the new minor error of keys Ctrl & N to display the "level" or the "? in 100"
as this is the same as the Ctrl & N for the "normals" and it does conflict?
I do think the keys Ctrl & G may be the better choice to display the "level"?

Good day and night for you
Hijau

HijauKuda

Posts : 102
Join date : 2012-01-18

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Wed Jun 12, 2019 12:07 pm

The Normals key is not set by default, so it's not quite a conflict.

Unfortunately, we're running out of default keys!

CTRL+G and G is currently in use (well reserved technically) for use shifting up or down a gearbox gear.

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by HijauKuda Wed Jun 12, 2019 6:18 pm

Sir leezer3
The keys G and Ctrl + G for the shift up and shift down gear It is I now see in the "customize" window.
I do think the keys Shift + Up and Shift +Down may be my simple mind choice of shifting hand gears?
I do not use have this in my trains although.

Good day and night for you
Hijau

HijauKuda

Posts : 102
Join date : 2012-01-18

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by Delsin Wed Jul 03, 2019 1:24 am

I might've posted about it months ago and apparently it was left unnoticed Rolling Eyes when in F2 view, the camera follows the first bogie of a car it's aimed at instead of the car itself. I thought it was a view sway function, but it seems to be a bug as I keep getting thrown outside of cars in curves when I put camera somewhere in the back of it.

Also, is there any way to optimize/increase performance of the way 3D models are processed/rendered/etc? It seems like the only serious limitation keeping the details and quality of models in openbve down.
Delsin
Delsin

Posts : 294
Join date : 2016-08-20

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 Wed Jul 03, 2019 12:12 pm

Delsin wrote:I might've posted about it months ago and apparently it was left unnoticed Rolling Eyes when in F2 view, the camera follows the first bogie of a car it's aimed at instead of the car itself. I thought it was a view sway function, but it seems to be a bug as I keep getting thrown outside of cars in curves when I put camera somewhere in the back of it.

Also, is there any way to optimize/increase performance of the way 3D models are processed/rendered/etc? It seems like the only serious limitation keeping the details and quality of models in openbve down.

The camera definitely seems to be following the car, and doesn't touch the bogie.
It's also performing some adjustments based upon the driver position / movement (track bounce & sway), which I suspect is probably what's moving the view out of the car.

TBQH, the F2 view wasn't really designed to be used internally, and my current view on this one is that it's a 'feature' not a bug that the camera swings to follow the movement of the front of the car.


With regards to the 3D models issue, the short answer is not really at the minute.
The longer answer is that it's being worked on, but is tied up with all of the rest of the problems inherant in the current way a lot of different things work.
In order to 'fix' one issue, a lot of other stuff needs working on in parallell.

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by graymac Wed Jul 03, 2019 1:00 pm

I'd noticed the same thing using F2 to sit myself "in" a car, especially the further the car is from the cab/front end. I wondered it was to do with the curve radius, in the same way a long object can be misaligned on a curve or need some rotation to "sit right".
Only using F2 within the interior of the front car seems to be fine (as seen in the promo videos on the CTS website or the celtictrainsim YouTube channel).
graymac
graymac

Posts : 2127
Join date : 2011-08-28
Location : Co Mayo, Eire

http://www.celtictrainsim.com

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by Delsin Thu Jul 04, 2019 6:24 pm

I thought it was a feature first, but throwing the view outside made me change my mind Smile probably having a way to disable it is a good idea for now. Thanks for the explanation
Delsin
Delsin

Posts : 294
Join date : 2016-08-20

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by SP1900 Thu Jul 04, 2019 6:45 pm

I find this feature interesting because for me it only happens on certain trains. Others keep you inside when turning curves. Very odd
SP1900
SP1900

Posts : 264
Join date : 2017-12-08
Age : 19
Location : Cambridge, England

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by Delsin Sat Jul 06, 2019 8:30 pm

ObjectViewer crashes when I load a train car's .animated, open train settings, tick "Enable train" and "The right door is anticipated to be open" in Doors tab and then click Apply. Not sure if I'm on the latest build tho
Delsin
Delsin

Posts : 294
Join date : 2016-08-20

Back to top Go down

openBVE 1.5.0 RC1 - BUGS - Page 18 Empty Re: openBVE 1.5.0 RC1 - BUGS

Post by Sponsored content


Sponsored content


Back to top Go down

Page 18 of 21 Previous  1 ... 10 ... 17, 18, 19, 20, 21  Next

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum