BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

bvec_ats.dll failed to load

Go down

bvec_ats.dll failed to load Empty bvec_ats.dll failed to load

Post by cilldroichid Fri Apr 30, 2021 9:21 pm

Hello,

On some of Graymacs Irish trains, 071, 201 and 2900, the plugin BVEC_ATS.dll fails to load in the 64 bit version of the latest release. With 22000, 2800, 2700, 141 and 121, the plugin loads. The plugin loads on all the trains in the 32 bit version. I've included the log file below.

Thanks  
Code:
openBVE Log: 30/04/2021 21:09:29
Program Version: v1.7.544.641-VssAdministrator

21:09:29  Using openGL 3.0 (new) renderer
21:09:29  Initialising full-screen game window of size 2560 x 1440
21:09:30  Game window initialised successfully.
21:09:30  Renderer initialised successfully.
21:09:30  E:\Program Files (x86)\OpenBVE\LegacyContent\Railway : Railway folder found.
21:09:30  INFO: 1 Route loading plugins available.
21:09:30  INFO: 6 Object loading plugins available.
21:09:30  INFO: 1 Sound loading plugins available.
21:09:30  Loading route file: E:\Program Files (x86)\OpenBVE\LegacyContent\Railway\Route\Portarlington\1320 Heuston-Portarlington(Portlaoise).csv
21:09:30  INFO: Route file hash AD5AECD55C8FC5B264F0090999ECDC409CCFD89F8ECC8A572C3737161DCBBE65
21:09:30  Route file format is: CSV
21:09:30  INFO: Using the Japanese compatibility signal set.
21:09:33  RailIndex 3 does not reference an existing dike in Track.DikeEnd at line 3540, column 1 in file E:\Program Files (x86)\OpenBVE\LegacyContent\Railway\Route\Portarlington\track-slow.txt
21:09:33  RailIndex 0 does not reference an existing dike in Track.DikeEnd at line 4382, column 1 in file E:\Program Files (x86)\OpenBVE\LegacyContent\Railway\Route\Portarlington\track-slow.txt
21:09:36  Route file loaded successfully.
21:09:36  Loading AI train: E:\Program Files (x86)\OpenBVE\LegacyContent\Train\29000.01_IE\29000 Commuter 4 car
21:09:36  The train.dat version openbve is invalid in E:\Program Files (x86)\OpenBVE\LegacyContent\Train\29000.01_IE\29000 Commuter 4 car\train.dat
21:09:36  Loading sound.cfg file: E:\Program Files (x86)\OpenBVE\LegacyContent\Train\29000.01_IE\29000 Commuter 4 car\sound.cfg
21:09:37  Loading player train: E:\Program Files (x86)\OpenBVE\LegacyContent\Train\29000.01_IE\29000 Commuter 4 car
21:09:37  The train.dat version openbve is invalid in E:\Program Files (x86)\OpenBVE\LegacyContent\Train\29000.01_IE\29000 Commuter 4 car\train.dat
21:09:37  Loading sound.cfg file: E:\Program Files (x86)\OpenBVE\LegacyContent\Train\29000.01_IE\29000 Commuter 4 car\sound.cfg
21:09:37  Loading train panel: E:\Program Files (x86)\OpenBVE\LegacyContent\Train\29000.01_IE\29000 Commuter 4 car\panel2.cfg
21:09:38  Train panel loaded sucessfully.
21:09:38  Loading train plugin: E:\Program Files (x86)\OpenBVE\LegacyContent\Train\29000.01_IE\29000 Commuter 4 car\BVEC_ATS.dll
21:09:39  The train plugin BVEC_ATS.dll failed to load.

cilldroichid

Posts : 25
Join date : 2014-09-28

Back to top Go down

bvec_ats.dll failed to load Empty Re: bvec_ats.dll failed to load

Post by leezer3 Sat May 01, 2021 1:43 pm

That's interesting (and I suppose techincally my fault, as BVEC_ATS was designed / coded by me too)

I seem to have compiled the earlier of the two in 32-bit only mode.
Later builds are compiled in AnyCPU mode, hence why they work.

I've added a more specific log error for this case.

Copying the BVEC_ATS.dll from any of the working copies to the others should be fine, or just use the 32-bit copy Smile
I'll drop graymac a message and hopefully he can swap out the broken copy in the others.

leezer3

Posts : 1785
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

bvec_ats.dll failed to load Empty Re: bvec_ats.dll failed to load

Post by cilldroichid Sat May 01, 2021 4:17 pm

Thanks,

Replacing the BVEC_ATS.dll worked after amending the the BVEC_ATS.cfg file. After the first copy the plugin still wouldn't load with the log file showing this error:
Code:
16:02:36  Loading train plugin: E:\Program Files (x86)\OpenBVE\LegacyContent\Train\071_IE\071_lightloco\BVEC_ATS.dll
16:02:36  The train plugin BVEC_ATS.dll failed to load for the following reason: Error loading the configuration file: The parameter pantographfitted is not supported.

Deleting the pantographfitted=false line in the .cfg done the trick and all the affected Irish trains now load in the 64 bit version.

cilldroichid

Posts : 25
Join date : 2014-09-28

Back to top Go down

bvec_ats.dll failed to load Empty Re: bvec_ats.dll failed to load

Post by leezer3 Sat May 01, 2021 4:29 pm

No trouble Smile

Will get *something* done about this, just need to figure out the best way forward.

leezer3

Posts : 1785
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

bvec_ats.dll failed to load Empty Re: bvec_ats.dll failed to load

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum