BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Train folder allocation problem

Go down

Train folder allocation problem Empty Train folder allocation problem

Post by Bill McG Mon Apr 13, 2020 10:14 am

Hello all. I was a regular, happy and experienced user of both BVE then OpenBVE with UK routes and trains for a long time. After installing Windows 10 and updating, etc., I can no longer run OpenBVE. I have downloaded the latest version (OpenBVE 1.7.1.3) and have the routes, trains etc. in the appropriate folders. However, on start up, the .exe file goes to App Data folder instead of program files, and the following message appears when I try and load the appropriate train, e.g.: The default train could not be found:\n\nVoyager_openbve

I don't have an "n" drive nor any n.... train names. Once I re-address to the train folder and the correct train appears, an error message comes up saying that the porgram no longer works and is being referred to Microsoft for a solution but nothing happens.

Can anyone advise what to do please?

Thanks, Bill

Admin edit: Please use sensible, meaningful thread titles. Thanks

Bill McG

Posts : 5
Join date : 2020-04-13

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by DR102 Mon Apr 13, 2020 12:53 pm

Hi Bill. 

Personally If I were you I'd uninstall Open BVE. 
And install a fresh copy of the latest stable version. 

As found at openbve-project (DOT) net (The forum won't let me post links because I'm a "new user").

During the installation process it will ask if you want to create a desktop shortcut of the addons folder. Select yes, and use this to access the folder. You know for sure you'll be in the correct place then.

On my computer (Win 10) it is at the destination "C:\Users\USERNAME\AppData\Roaming\openBVE\LegacyContent"

Also check in the settings section of the Open BVE that your addons location is set correctly within the program.

Settings > Next Page and then the top 3 boxes... The below screenshot will show you how mine look.

Train folder allocation problem Screenshot-settings

Hopefully that helps.
DR102
DR102

Posts : 5
Join date : 2020-04-11
Location : West Middle Lands

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by leezer3 Mon Apr 13, 2020 6:41 pm

On more modern versions of Windows, it's a *bad* idea to store things in the Program Files folder, which I suspect is a good part of the problem. (Windows will attempt to block non-elevated programs from accessing / writing here)


The default train could not be found:\n\nVoyager_openbve

Please ignore the \n\n in this, these were supposed to be new-lines, but seem to have been mangled (will fix in a minute).

If your issue is related to the Program Files folder as I suspect, either right-click on the shortcut and select Run as Administrator (you can permenantly set this in the properties), or move the routes / trains out of the Program Files folder.


Also, please hit the link in the bottom left of the form: Report Problem
From here, I'd like to see the text from the most recent crash log; If it's not program files related, might help me figure out what's going on Smile

leezer3

Posts : 1785
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by Bill McG Sat Apr 18, 2020 2:01 pm

Thanks chaps. Just got round to doing the job. Have re-installed the latest issue from the DR102 suggested web site and transferred all the add-ons to the appdata/roaming area.  Still no luck. It appears to load, coming up with the Japanese loco on the front, loads to 100% then drops back to the menu part of the programme. Have sent a report as suggested too.

Bill McG

Posts : 5
Join date : 2020-04-13

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by Bill McG Sun Apr 19, 2020 5:15 pm

Just tried starting now and there's the crash log:

19/04/2020 16:58:11
OpenBVE 1.7.1.3 Crash Log
Program is running on the Windows backend
Current screen resolution is: Full-screen 1024px X 768px 32bit color-mode
Current routefile is: C:\Users\Bill_DELL_OPTIPLEX\AppData\Roaming\openBVE\LegacyContent\Railway\Route\Network West Midlands 2014\2006-2010 era\12.47 [57005] Salford Bridge-Kings Head Sidings empty KEA.csv
Current train is: C:\Users\Bill_DELL_OPTIPLEX\AppData\Roaming\openBVE\LegacyContent\Train\cl57 005 Advenza Freight Scrap Steel Empty OPEN
Current train plugin is: UKDt.dll
The current routefile caused the following exception: 
System.Exception: Exception of type 'System.Exception' was thrown.
   at LibRender2.Objects.VisibleObjectLibrary.ShowObject(ObjectState State, ObjectType Type)
   at OpenBve.Host.ShowObject(ObjectState objectToShow, ObjectType objectType)
   at OpenBve.TrainManager.CarSection.Show()
   at OpenBve.TrainManager.Car.ChangeCarSection(CarSectionType newCarSection)
   at OpenBve.TrainManager.Train.Update(Double TimeElapsed)
   at OpenBve.TrainManager.Train.Initialize()
   at OpenBve.OpenBVEGame.SetupSimulation()
   at OpenBve.OpenBVEGame.LoadingScreenLoop()
   at OpenBve.OpenBVEGame.OnLoad(EventArgs e)
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second) in I:\work\github\opentk\src\OpenTK\GameWindow.cs:line 349
   at OpenBve.MainLoop.StartLoopEx(MainDialogResult result)
   at OpenBve.Program.Main(String[] args)   at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   at System.Environment.get_StackTrace()
   at OpenBve.Program.Main(String[] args)
Current program memory usage: 174.53mb
System memory free: 1274mb

Wonder if this shows the fault?
Bill

Bill McG

Posts : 5
Join date : 2020-04-13

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by leezer3 Sun Apr 19, 2020 6:14 pm

It's attempting to load the 3D exterior of the train, and there's something it does not like there.

First thing I'd try is another train, so we can figure out if it's an isolated issue with one, or a wider issue with all.

The 57 from here?
https://sites.google.com/a/bve4trains.com/open-bve-trains/Home/class-57

leezer3

Posts : 1785
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by Bill McG Sun Apr 19, 2020 10:31 pm

19/04/2020 22:28:51
OpenBVE 1.7.1.3 Crash Log
Program is running on the Windows backend
Current screen resolution is: Full-screen 1920px X 1080px 32bit color-mode
Current routefile is: C:\Users\Bill_DELL_OPTIPLEX\AppData\Roaming\openBVE\LegacyContent\Railway\Route\Network West Midlands\2006-2010\15.00 [57312] Maybank-Radley Junction via loop Pendolino drag.csv
Current train is: C:\Users\Bill_DELL_OPTIPLEX\AppData\Roaming\openBVE\LegacyContent\Train\cl57 005 Advenza Freight Scrap Steel Empty OPEN
Current train plugin is: UKDt.dll
The current routefile caused the following exception: 
System.Exception: Exception of type 'System.Exception' was thrown.
   at LibRender2.Objects.VisibleObjectLibrary.ShowObject(ObjectState State, ObjectType Type)
   at OpenBve.Graphics.NewRenderer.InitializeVisibility()
   at OpenBve.OpenBVEGame.SetupSimulation()
   at OpenBve.OpenBVEGame.LoadingScreenLoop()
   at OpenBve.OpenBVEGame.OnLoad(EventArgs e)
   at OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second) in I:\work\github\opentk\src\OpenTK\GameWindow.cs:line 349
   at OpenBve.MainLoop.StartLoopEx(MainDialogResult result)
   at OpenBve.Program.Main(String[] args)   at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   at System.Environment.get_StackTrace()
   at OpenBve.Program.Main(String[] args)
Current program memory usage: 157.98mb
System memory free: 956mb

Bill McG

Posts : 5
Join date : 2020-04-13

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by S520 Mon Apr 20, 2020 12:49 am

Your problem may be resolved by the pull request below.
https://github.com/leezer3/OpenBVE/pull/433
https://github.com/leezer3/OpenBVE/pull/437

Please try the latest development version.
http://vps.bvecornwall.co.uk/OpenBVE/Builds/
S520
S520

Posts : 113
Join date : 2018-08-24
Location : Japan

https://github.com/s520

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by leezer3 Mon Apr 20, 2020 10:29 am

That's a good call Smile
I've tried 57 and routefile above, which work OK here.

If the most recent development version solves the immediate problem, this would suggest that your graphics drivers are failing to create an openGL 3.0 context, and I'd try updating them.

leezer3

Posts : 1785
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by Bill McG Thu Apr 23, 2020 5:34 pm

Thanks chaps. Just taken delivery of a "new" (second hand) PC that is miles faster than my other one. Downloaded the BVE (Cornwall) and Open AL so now ready to search for routes and trains.

Bill McG

Posts : 5
Join date : 2020-04-13

Back to top Go down

Train folder allocation problem Empty Re: Train folder allocation problem

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum