BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New

4 posters

Go down

Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New Empty Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New

Post by Cool Games Network Wed Dec 15, 2021 6:09 pm

I am totally new to OpenBVE and find nothing to do but wander around the files after installing Barcelona.

I see EXE so expect I need to install other system apps but not sure which.
Is there a Linux user documentation somewhere ?

System is Ubuntu 21.10 
Code:
$ cat /etc/os-release
PRETTY_NAME="Ubuntu 21.10"
NAME="Ubuntu"
VERSION_ID="21.10"
VERSION="21.10 (Impish Indri)"
VERSION_CODENAME=impish
ID=ubuntu
ID_LIKE=debian
UBUNTU_CODENAME=impish



I can't under stand why the simulator can't get "start new game" to respond.

STEPS
Download 1.8.2.1 deb and install

Code:
$ dpkg -l openbve
||/ Name           Version      Architecture Description
+++-==============-============-============-===================================================
ii  openbve        1.8.2.1      all          realistic 3D train/railway simulator (main program)




Download and package install Barcelona trains the routes.

Code:
$ ls .config/OpenBve/LegacyContent/
Railway  Train
$ ls .config/OpenBve/LegacyContent/Train/
'FCMB 2000'  'FCMB 3000'
$ ls .config/OpenBve/LegacyContent/Railway/Route/
'Animated Object Demonstration Route.csv'  'Metro de Barcelona - L3'




Nothing happens when I press "Start New Game".

What am I missing ?
Cool Games Network
Cool Games Network

Posts : 3
Join date : 2021-12-15

Back to top Go down

Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New Empty Re: Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New

Post by Quork Thu Dec 16, 2021 12:53 am

I have virtually no knowledge of Linux and also am in a hurry, so just one note: The .exe you'll occasionally find for older addons are virtually always just a self-unpacking zip archive, so a zip with a small unpacker binary for Windows integrated into it. 7zip, which, as far as I know, is available on Linux as well, will treat it just like any other archive and unpack it cleanly without any problems.
Quork
Quork

Posts : 1425
Join date : 2012-05-05
Age : 31
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New Empty Re: Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New

Post by Cool Games Network Thu Dec 16, 2021 1:12 am

Thanks,
I have been getting some success exporting on Wine then copying to alternative location.
The EXE as a ZIP I remember now.

Next issue is Raildriver for BVE is NOT Linux ready so am using JMRI debugger to get experience on the controls.
And BTW, Raildriver is abandoned there as well but Matt at PI is being responsive to my plight.
Cool Games Network
Cool Games Network

Posts : 3
Join date : 2021-12-15

Back to top Go down

Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New Empty Re: Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New

Post by leezer3 Thu Dec 16, 2021 3:11 am

I'll be honest-
I haven't even considered implenting the RailDriver on Linux or tried testing it. We just import the PI DLL under Windows, which handles all the HID comms for us.
IIRC PI have published the HID specs for it, so it wouldn't necessarily be insurmoutable / *too* difficult, but I've never tried writing a HID driver from scratch either....

Not sure how it handles calibration under Linux either; Mine certainly needs it under Windows to work OK.


The 'Start Game' button not working is a little odd- is it actually clickable?
It certainly works on my Debian VM without any messing around.
My first thought would be it can't find the train, and you might need to browse for them manually.

leezer3

Posts : 1873
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New Empty Re: Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New

Post by Cool Games Network Thu Dec 16, 2021 2:23 pm

I have found the train and route because I assumed the install location somehow was the default place to look.
In fact it is not.
Now working so am learning how to run a train from keyboard.

As for the PI Engineering Raildriver, I am testing JMRI which has open source to explain how to implement the controls.
In Jan 2021 there appears to be renewed interest in making it work again as JMRI throttle for model trains.
Cool Games Network
Cool Games Network

Posts : 3
Join date : 2021-12-15

Back to top Go down

Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New Empty Re: Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New

Post by CaptED Sat Jan 01, 2022 4:25 pm

Hello, I have sent you a PM (Private Message) about the Linux setup
Ed
CaptED
CaptED

Posts : 75
Join date : 2012-08-19
Age : 78
Location : Bryant, Arkansas

Back to top Go down

Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New Empty Re: Ubuntu Linux 21.10 with OpenBVE v1.8.2.1 using Barcelona - Can't Start New

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum