BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Object disappearance in Route Viewer

Go down

solved Object disappearance in Route Viewer

Post by LXQt Sat Aug 22, 2020 7:35 am

I was told that the memory leak issue is fixed in the latest nightly build, so I downloaded the 20-08-2020 build. The ObjectViewer memory leak is fixed, but something is clearly wrong with Route Viewer.

Loading some of the route, you would notice that the back of the station is missing, including wall and rail.

On ANY route, and I mean even an route with only 3 object. The route would be chopped off after 700-1000m. No Rail, Wall, Object or ground will exist anymore, leaving only the background. (Some small object do spawn, but alot won't)

Object disappearance in Route Viewer FWFkcIC
Object disappearance in Route Viewer Sh4DpIa

LXQt

Posts : 106
Join date : 2019-02-18
Age : 16
Location : Hong Kong

https://kennyhui.pp.ua

Back to top Go down

solved Re: Object disappearance in Route Viewer

Post by S520 Sat Aug 22, 2020 9:22 am

I was able to reproduce this issue.

I have submitted a pull request to fix this issue.
https://github.com/leezer3/OpenBVE/pull/515

Also, I have prepared a modified binary, so please try it.
https://drive.google.com/file/d/104i9svk9dwK89aduOIFgqPBht8LUu6uP/view?usp=sharing

That pull request was merged, so today's nightly build should have fixed this issue. Please try it.
https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2020-08-22.zip


Last edited by S520 on Sat Aug 22, 2020 10:53 am; edited 1 time in total (Reason for editing : The pull request has been merged.)
S520
S520

Posts : 113
Join date : 2018-08-24
Location : Japan

https://github.com/s520

Back to top Go down

solved Re: Object disappearance in Route Viewer

Post by LXQt Sat Aug 22, 2020 12:22 pm

S520 wrote:I was able to reproduce this issue.

I have submitted a pull request to fix this issue.
https://github.com/leezer3/OpenBVE/pull/515

Also, I have prepared a modified binary, so please try it.
https://drive.google.com/file/d/104i9svk9dwK89aduOIFgqPBht8LUu6uP/view?usp=sharing

That pull request was merged, so today's nightly build should have fixed this issue. Please try it.
https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2020-08-22.zip
Thanks, however there is another problem on the new build.
When reloading route on RouteViewer, the speed is abnormally fast, it only reload the route.csv itself, but not the object.

LXQt

Posts : 106
Join date : 2019-02-18
Age : 16
Location : Hong Kong

https://kennyhui.pp.ua

Back to top Go down

solved Re: Object disappearance in Route Viewer

Post by S520 Sat Aug 22, 2020 2:09 pm

In the development version, objects are now cached for faster loading.
I should have cleared the cache when reloading the route in RouteViewer, but I did not.
I have prepared a binary that fixes this issue, so give it a try.
https://drive.google.com/file/d/1HKWjbiAMMbxCJVDoMaNUMfRg9cbCAXlt/view?usp=sharing
S520
S520

Posts : 113
Join date : 2018-08-24
Location : Japan

https://github.com/s520

Back to top Go down

solved Re: Object disappearance in Route Viewer

Post by LXQt Sat Aug 22, 2020 3:07 pm

S520 wrote:In the development version, objects are now cached for faster loading.
I should have cleared the cache when reloading the route in RouteViewer, but I did not.
I have prepared a binary that fixes this issue, so give it a try.
https://drive.google.com/file/d/1HKWjbiAMMbxCJVDoMaNUMfRg9cbCAXlt/view?usp=sharing
Everything worked fine, thanks!

LXQt

Posts : 106
Join date : 2019-02-18
Age : 16
Location : Hong Kong

https://kennyhui.pp.ua

Back to top Go down

solved Re: Object disappearance in Route Viewer

Post by S520 Sat Aug 22, 2020 10:56 pm

Glad it worked out.

This fix has been merged into the master branch.
https://github.com/leezer3/OpenBVE/pull/516
The latest nightly builds, this problem has been resolved.

Administrator or moderator, please mark this topic as resolved.

---

Marked as solved / closed.
S520
S520

Posts : 113
Join date : 2018-08-24
Location : Japan

https://github.com/s520

Back to top Go down

solved Re: Object disappearance in Route Viewer

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum