BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

PassAlarm system does not work

2 posters

Go down

PassAlarm system does not work Empty PassAlarm system does not work

Post by gcs7e7 Sun May 17, 2020 6:40 pm

Hi there!

I've tried to use the PassAlarm system in one of my vehicles, but doesn't work (Sound effect and indicator lamp too).
I think everything was set correctly:

  • .Sta in route file: https://pasteboard.co/J8OU16g.png
  • An indicator lamp in the Panel.animated: https://pasteboard.co/J8OU88u.png
  • System in the Train.dat: https://pasteboard.co/J8OUfq7.png
  • And the sound effect in the Sound.cfg: https://pasteboard.co/J8OUjRN.png



  • Windows 10 1909
  • OpenBve 1.7.1.5


Thanks in advance!

gcs7e7

Posts : 26
Join date : 2018-08-25
Age : 22
Location : Budapest, Hungary

https://facebook.com/bveworks/

Back to top Go down

PassAlarm system does not work Empty Re: PassAlarm system does not work

Post by leezer3 Mon May 18, 2020 11:42 am

From a first brief poke, it appears to be working here with your posted station.

My first suspicion would be that you're not quite using it as expected; Were you expecting it to continue until cancelled?

The PassAlarm triggers 150m before the start of the station. (6 blocks- If you're using a non-standard block length, this may be different, will sort this)
With your current settings (Pass alarm type of 1), the sound effect will play once at this point.
The light should stay lit until you exit the station zone, so anything upto about 300m or so depending on your stop point setups.

With what I can see, the sound will play once at 5300m & the light will come one. The light will go out at 5460m.

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

PassAlarm system does not work Empty Re: PassAlarm system does not work

Post by gcs7e7 Tue May 19, 2020 6:15 pm

I expected that too.

The goal is for the sound to play once when the system activated, and the indicator light turn on until stop at the station.
I want to use it as a stop request button for "passengers".

We're using 2m block length, I tried it on a standard 25m block length route too, but it didn't worked too.
This is the indicator light:
PassAlarm system does not work Base_p12
Here's a video:
https://youtu.be/eT93GW0qzdc

Another topic:
I tried to use [Sound] section in animated files too.
This is a powerless section indicator light (top left), and it have a sound effect in real life.
Code:
[Object]   ;;;;;;;;;;;;;;;;;;;;;;;;;;;;HÁLÓZATI FESZÜLTSÉG
States = ../_vezetoallas/visszajelzo_sarga/g_0.b3d, ../_vezetoallas/visszajelzo_sarga/g_1.b3d
Position = -0.421, 1.898, 7.19
StateFunction = if[pluginstate[2] == 0,1,0]
RotateXFunction = 0.53

[Sound]
FileName = ../_sound/zavarjelzes.wav
Position = -0.421, 1.898, 7.19
Volume = 1
Pitch = 1
VolumeFunction = if[pluginstate[2] == 0,1,0]
As you can se on the video, the light turn on under this section, but the sound effect doesn't play. And the animation is the same.
https://youtu.be/uoPFMy1Racc

gcs7e7

Posts : 26
Join date : 2018-08-25
Age : 22
Location : Budapest, Hungary

https://facebook.com/bveworks/

Back to top Go down

PassAlarm system does not work Empty Re: PassAlarm system does not work

Post by leezer3 Tue May 19, 2020 8:26 pm

I'll do a little more investigating and see what I can come up with, probably something stupid going on.

2m block length is highly unusual, and it wouldn't surprise me if other unexpected things break.

Sounds
Sounds in an animated file are only currently supported on non-train objects, sorry Sad
(At the time of implementation, this wasn't even considered; Trains can play whatever sounds they like via the plugin interface)

Needs to be revisited, shouldn't be *too* much hastle to sort.

leezer3

Posts : 1802
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

PassAlarm system does not work Empty Re: PassAlarm system does not work

Post by gcs7e7 Thu May 21, 2020 4:30 pm

Ok, thank you. Smile
Yes, but it didn’t work with the 25m block length too.

Oooh ok, this was not included in the documentation. Very Happy
But it will be included later?

gcs7e7

Posts : 26
Join date : 2018-08-25
Age : 22
Location : Budapest, Hungary

https://facebook.com/bveworks/

Back to top Go down

PassAlarm system does not work Empty Re: PassAlarm system does not work

Post by gcs7e7 Fri Jun 05, 2020 1:12 pm

I tried with version 1.7.1.6 but it didn't work too.

gcs7e7

Posts : 26
Join date : 2018-08-25
Age : 22
Location : Budapest, Hungary

https://facebook.com/bveworks/

Back to top Go down

PassAlarm system does not work Empty Re: PassAlarm system does not work

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum