BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Unable to load wavefront object in Object Viewer

3 posters

Go down

Unable to load wavefront object in Object Viewer Empty Unable to load wavefront object in Object Viewer

Post by LXQt Mon Mar 09, 2020 3:09 am

Whenever I load an wavefront obj(.obj) into object viewer,I will get the following error:
Unable to load wavefront object in Object Viewer CH17OVn
This error occurred in both 1.7.1.3 and 1.7.0.3(which I assume it would also error on other versions)
I've tried exporting different Wavefront obj file in blender(and download some from the internet), however it still can't load the object.
My first thought is object viewer doesn't support .obj(as it's not listed in the docs), but apparently it allows you to choose an obj file and it did attempt to load, so what's going on?

LXQt

Posts : 107
Join date : 2019-02-18
Age : 16
Location : Hong Kong

https://kennyhui.pp.ua

Back to top Go down

Unable to load wavefront object in Object Viewer Empty Re: Unable to load wavefront object in Object Viewer

Post by zbx1425 Mon Mar 09, 2020 11:32 am

OpenBVE has recently been refactoring the parsers into plugins, so my personal guess is something broke down in this process.
The obj parser was working fine half a year ago...
zbx1425
zbx1425

Posts : 137
Join date : 2017-08-18
Location : China

https://www.zbx1425.cn

Back to top Go down

Unable to load wavefront object in Object Viewer Empty Re: Unable to load wavefront object in Object Viewer

Post by leezer3 Mon Mar 09, 2020 11:54 am

The error you're seeing suggests that the wavefront parser doesn't like the object, which I don't think has been recently broken. (Switching to Assimp from the options dialog may make things work)

Unfortunately, I wouldn't claim the Wavefront parser to be anything near perfect- I wrote it Razz

I've found a couple of new issues, which I've fixed for this build (Exponential numbers in the Assimp parser, and objects using a separate material file in the old parser), but I really need to see something broken if this doesn't help:
https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2020-03-09.zip

leezer3

Posts : 1803
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Unable to load wavefront object in Object Viewer Empty Re: Unable to load wavefront object in Object Viewer

Post by LXQt Mon Mar 09, 2020 12:05 pm

Thanks, I've found out that switching to Assimp fixes the problem

LXQt

Posts : 107
Join date : 2019-02-18
Age : 16
Location : Hong Kong

https://kennyhui.pp.ua

Back to top Go down

Unable to load wavefront object in Object Viewer Empty Re: Unable to load wavefront object in Object Viewer

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum