BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

X files problem, need help

Go down

X files problem, need help Empty X files problem, need help

Post by NakanoS Fri Nov 15, 2019 2:27 am

Greetings. I have a little problem here.

So few years ago i made several X objects for my route and it works normally in older version. I want to update the route. But now, since OpenBVE have new options for X objects i found my objects can't display anymore at ANY version. I tried to change options for X object with all 3 different methods and nothing works.

Also i tried to open them at older version, started from 1.4.3 until latest one. Now, no one can load it. Can be that file being corrupted? Or should i did something to make it clear? To be honest, i can't make all of them again with B3d files because have no time to do that (and there are hundreds of themĀ  Sad)
Attachments
X files problem, need help Attachment
19467625_341357042950080_110419697809721676_o.jpg Old picture, before X object dissapearYou don't have permission to download attachments.(271 Kb) Downloaded 10 times
X files problem, need help Attachment
20988518_1922843061309203_8256538194181777704_o.jpg Also old pict. Pole, Platform, and roof using X objectsYou don't have permission to download attachments.(286 Kb) Downloaded 7 times
X files problem, need help Attachment
cats.jpg No X objects appear now, with that error include (i don't know how to deal with that error tho)You don't have permission to download attachments.(280 Kb) Downloaded 11 times
NakanoS
NakanoS

Posts : 23
Join date : 2017-11-09
Age : 24
Location : Bandung, Indonesia

http://javvasharyo.weebly.com

Back to top Go down

X files problem, need help Empty Re: X files problem, need help

Post by leezer3 Tue Nov 19, 2019 10:25 am

Any chance of a copy of one of the missing files please?

Don't need any textures, just the file itself Smile

Would also be interesting to know if you can open it in Object Viewer and the main sim.

---

For your error, let's say you had the following (rather simplified) code in your structure section:
.freeobj(0) myobject.x
.freeobj(1) mysecondobject.x
.freeobj(0) mythirdobject.x

Note that FreeObject 0 is declared twice, but pointing to different object files.

Now attempt to use this later in your route:
2000, .freeobj 0;0;0

The sim has no way of knowing which you intended to appear there, so I've kept the behaviour of using the last (latest) declared, and added a specific warning for this.

leezer3

Posts : 1785
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum