BVE WorldWide
Would you like to react to this message? Create an account in a few clicks or log in to continue.

openBVE extreme lag

Go down

openBVE extreme lag Empty openBVE extreme lag

Post by LXQt Fri Jul 26, 2019 11:48 am

I develop and play openBVE routes sometimes. Most of them are getting about 30-50 fps(60 if lucky enough) however recently I played openBVE again and now I only got 7-15 fps. I closed all the application(most but should be enough to run at about 30-45 fps) and opened up GPU-Z, however I found nothing. CPU load is about 24%, RAM is about 24%. GPU Load is 21% and the GPU memory is 849MB/1GB on my GTX 650 Ti BOOST. My computer should be able to make it run alot smoother. and a day before it start lagging. I haven't changed any hardware and software settings. So is that a bug..... or I need to change some settings to make it to work...? I have no idea.

p.s. I did not change or update any of my graphic drivers. But it start to lag the next day. I updated my graphic driver now but still lagging like hell

openBVE extreme lag D1hHM97

LXQt

Posts : 106
Join date : 2019-02-18
Age : 16
Location : Hong Kong

https://kennyhui.pp.ua

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by BillEWS Tue Aug 20, 2019 1:51 pm

I found lagging in OpenBVE after a Windows 10 update and just had to live with it. Then it cleared after the next Windows update. I don't know why this should be. I expect to find problems will various programmes after Window 10 updates. In Particular by PageBreeze HTML Editor tends to require reinstalling after every Windows 10 update.

BillEWS

Posts : 133
Join date : 2012-05-10
Location : South Oxfordshire

http://theatreorgans.com/hammond/keng/kenhtml/GKHome.htm

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by mikedexion Sat Nov 16, 2019 3:48 pm

Yeah, I know what you mean. I have a GTX 1070 Ti, AMD Ryzen 5 2600 w/16GB RAM and the (4) line with the R142A gets me down to 24fps exterior view. OpenBVE has this strange anomaly where GPUs are either idle or half-way working which sucks for framerates. Fortunately my monitor has a motion smoothing feature which keeps it fluid.

mikedexion

Posts : 11
Join date : 2019-09-07

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by BillEWS Sun Nov 17, 2019 2:26 pm

I'm getting virtually 60fps continuously. However, a few years back I started getting very low frame rates and couldn't work out how to improve things. Some while later, by chance I decided to make a back-up copy of OpenBVE onto a memory pen and when running OpenBVE from that I got maximum continually. I know the programme should run correctly on a PC or Lap Top but perhaps you might give copying the whole game as a stand alone onto a memory Pen or Card and see what happens! I haven't had frame rate problems with OpenBVE for a long time and think the problem was resolved when I had a Hard Drive  crash and replaced.

BillEWS

Posts : 133
Join date : 2012-05-10
Location : South Oxfordshire

http://theatreorgans.com/hammond/keng/kenhtml/GKHome.htm

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by LXQt Mon Nov 18, 2019 2:37 am

Alright so I have a dual boot between windows 8.1 and windows 10,so recently I've booted to the windows 10,everything is kinda smooth and became normal again,however I found out sometimes if either Object Viewer or OpenBVE itself is running on full screen, it will basically use all of my gpu(yes, 100% load,with like 2 fps). This does not have anything to do with the size or how many face the object has. Even with empty scenery, I still sometimes get that, and apparently only OpenBVE have this problem.

p.s. if I run it on a smaller window, it's still normal gpu usage,but after a specific resolution, it happens.

LXQt

Posts : 106
Join date : 2019-02-18
Age : 16
Location : Hong Kong

https://kennyhui.pp.ua

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by mikedexion Thu Nov 21, 2019 3:07 am

Try this: Go into options in OpenBVE, and make sure you have the following features enabled or disabled.

Window mode or Fullscreen mode doesn't really matter if you have a decent GPU.
Interpolation: Anisotrophic Filtering level 0 or 2x AA 0-2x
Transparency: Sharp (makes a big fps boost as opposed to Smooth
Viewing distance 400-600
------------------------------------------------------
Next page:
Advanced Options: Load in Advance (check)
Disable OpenGL display lists (leave unchecked)
Attempt to fix transparency issues in older content. (check)
Enable hacks for buggy older content (check)

These gave me the best fps in exterior view possible. In cab view I get 100-140fps. I believe the main issue is OpenBVE is just not an efficient engine and everything seems to be bottle-necked by the game engine when you load a full sized train.

mikedexion

Posts : 11
Join date : 2019-09-07

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by mikedexion Sat Nov 23, 2019 11:47 pm

So I found out what the biggest source of lag is in OpenBVE, other AI trains... sometimes I have two of them per route. You have to open the route with Notepad and delete a line which should be the 4th one down called "RunInterval xxx" <-DELETE THIS LINE

mikedexion

Posts : 11
Join date : 2019-09-07

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by leyland1195 Wed Nov 27, 2019 1:10 pm

Hi Guys,

What frame rates do you get on Network west midlands?

I am getting 10-20fps maximum 

My specs are 

FX8320 3.4Ghz
GTX1070 
8GB Ram
1000GB Hard drive

Not sure if its the game struggles with the AI?

or if I need to change a graphic or PC setting

Thanks

leyland1195

Posts : 34
Join date : 2012-09-24

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by BillEWS Wed Nov 27, 2019 2:12 pm

This is quite an old game and uses quite low res images, so frame rates should not be a problem to any computer from at least 10 years old. File sizes as compared to say, Train Simulator 2020 are nothing. I would think most frame rate problems would have to do with how you have the folders and files set up and that you have all the third party files required. Check out what files and folders are necessary, especially on 'C' drive that should be read when your computer is booted up. I don't remember the file names now but you had to download them yourself from information given with BVE & OpenBVE. However I think Windows 10 have these already built-in. OpenBVE ran without problems from my first update of Windows 10.

I remember when frame rates used to drop to around 10 when I first ran into Birmingham New street in the Birmingham_Cross-City_South route. Normal frame rates were around 35-40. My computer (HP Pavillion HPE series) is a good eight years old but is still giving a constant 60 fps and remains steady when running into Birmingham New Street.

BillEWS

Posts : 133
Join date : 2012-05-10
Location : South Oxfordshire

http://theatreorgans.com/hammond/keng/kenhtml/GKHome.htm

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by LXQt Sun Dec 15, 2019 3:41 am

BillEWS wrote:This is quite an old game and uses quite low res images, so frame rates should not be a problem to any computer from at least 10 years old. File sizes as compared to say, Train Simulator 2020 are nothing. I would think most frame rate problems would have to do with how you have the folders and files set up and that you have all the third party files required. Check out what files and folders are necessary, especially on 'C' drive that should be read when your computer is booted up. I don't remember the file names now but you had to download them yourself from information given with BVE & OpenBVE. However I think Windows 10 have these already built-in. OpenBVE ran without problems from my first update of Windows 10.

I remember when frame rates used to drop to around 10 when I first ran into Birmingham New street in the Birmingham_Cross-City_South route. Normal frame rates were around 35-40. My computer (HP Pavillion HPE series) is a good eight years old but is still giving a constant 60 fps and remains steady when running into Birmingham New Street.
Although this game is getting little old, developers now develop higher quality project, also OpenBVE use ancient rendering engine(which was a decade old I believe) and it's simply not efficient enough to handle complex modelling. I can get higher/same fps on other simulator such as Flight Simulator while rendering more object with lots of 3D building.

LXQt

Posts : 106
Join date : 2019-02-18
Age : 16
Location : Hong Kong

https://kennyhui.pp.ua

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by BillEWS Sun Dec 15, 2019 11:29 am

I'm sure OpenBVE can be considerably improved with updates by those who understand the programming. Things went very quiet on this front but has increased activity lately. Thanks to authors such as Graymac with his excellent Irish and Welsh routes and of course, NWM package OpenBVE can still be enjoyed. I have just recently downloaded version 1.7.0.3 and it all ran perfectly from first go.

Eezypeazys East Coast Northumberland and Tyne Valley routes are still perfectly playable. We lost another great Route Builder when he left. These two routes could have been kept updated. 

The Edinburgh To Aberdeen too would be even better if it was updated. I hadn't played that for quite a while but just a few days ago ran it fully with a break at Dundee and thoroughly enjoyed it. It would be great to see this route updated.

I have both Train Sim 2019 and Train Sim World and enjoyed the vast improvements on there but I am only getting 25-30 FPS with TS and a very poor 12-16 fps with Train Sim World and with ALL Low Settings that makes it just bearable to play. I don't feel like purchasing any new routes while these frame rates continue. As my computer went in for a Hard Drive replacement I decided to upgrade the ram from 8 to 16gb but that didn't make a bit of difference to the frame rates with these two games. 

It has always been a disappointment that Watford to Rugby and Birmingham Cross City North have never been published although the updates to NWM is very close to that quality but feel that the publication of these two routes would give OpenBVE a big push. I have never given up that these routes would appear some day and it may happen yet!


Last edited by BillEWS on Sun Dec 15, 2019 11:47 am; edited 1 time in total (Reason for editing : typo correction)

BillEWS

Posts : 133
Join date : 2012-05-10
Location : South Oxfordshire

http://theatreorgans.com/hammond/keng/kenhtml/GKHome.htm

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by mrknowitall Sun Dec 15, 2019 12:36 pm

Have faith in Anyhony. The routes will come! As always by graymac and the NWM team, the routes are amazing.
mrknowitall
mrknowitall

Posts : 822
Join date : 2011-07-09
Age : 29
Location : W. Yorkshire

https://www.pioneertrains.co.uk/

Back to top Go down

openBVE extreme lag Empty Re: openBVE extreme lag

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum