Strange Graphic Glitches

Go down

Strange Graphic Glitches

Post by Runnerbean on Thu Mar 15, 2018 1:30 pm

Hello guys,

Just started using openBVE. I seem to have a problem. I'm having a problem with nearly all London Underground routes. I'm fine when in the tunnels but as soon as I come out of the underground tunnels into the outside open above ground, I start getting these graphical glitches of all different colours. It means I just cannot drive because they're across the screen and distracting.

Is it because the routes are very old and not compatible with openBVE or have I not installed something correctly?

I'm sure I'm installing the files correctly in their folders but I notice when the route loads up there will always be files missing in the message top-left hand corner of screen. Is this causing the glitches?

Runnerbean

Posts : 7
Join date : 2018-03-14

Back to top Go down

Re: Strange Graphic Glitches

Post by SP1900 on Thu Mar 15, 2018 1:42 pm

Most of the London Underground routes are very old dating back to the BVE2/4 era in the early 2000s. It might have something to do with the version of openBVE you use. Try out different versions and see if any changes happen
avatar
SP1900

Posts : 149
Join date : 2017-12-08
Location : Cambridge, England

Back to top Go down

Re: Strange Graphic Glitches

Post by Runnerbean on Thu Mar 15, 2018 1:55 pm

Thanks but where do I get these older versions from please? What exactly am I looking for because I'm confused about openBVE BVE2 BV4. I've watched YouTube videos of a person playing these underground routes in openBVE.

Runnerbean

Posts : 7
Join date : 2018-03-14

Back to top Go down

Re: Strange Graphic Glitches

Post by SP1900 on Thu Mar 15, 2018 4:10 pm

Runnerbean wrote:Thanks but where do I get these older versions from please? What exactly am I looking for because I'm confused about openBVE BVE2 BV4. I've watched YouTube videos of a person playing these underground routes in openBVE.
Go to https://openbve-project.net/download/ and scroll down until you fin the previous stable builds. I recommend to start with version 1.4.3 it’s the one that a lot of developers like to use. But trial out different versions to see which ones work
avatar
SP1900

Posts : 149
Join date : 2017-12-08
Location : Cambridge, England

Back to top Go down

Re: Strange Graphic Glitches

Post by leezer3 on Thu Mar 15, 2018 6:14 pm

Links to the routes in question please Smile

I'm unaware of anything that's seriously broken with the LU routes, other than the tube tunnels on some of the BVE2 stuff, which looks like this:


This is on my list of things to add a hack for (IIRC it's to do with different behaviours for negative cylinder radii between BVE2, BVE4 and openBVE), but I haven't got to that one yet.....

Screenshots would also be nice, then we can see what's going on rather than guessing.

leezer3

Posts : 1200
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: Strange Graphic Glitches

Post by Runnerbean on Thu Mar 15, 2018 6:26 pm

I'm trying to upload a screenshot from my desktop but I keep getting this red alert message.

The picture is only 96Kb in size. I use to use Photbucket until they started charging. 

Could not upload file : exceeded total storage space. (Free space : 25)

Runnerbean

Posts : 7
Join date : 2018-03-14

Back to top Go down

Re: Strange Graphic Glitches

Post by leezer3 on Thu Mar 15, 2018 7:33 pm

It's the free forum, not a lot we can do about it Sad
https://imgur.com isn't too bad as an upload site.

I tend to use TinyPic for other reasons (post elsewhere which doesn't like imgur), but they're ad infested when you upload.....

leezer3

Posts : 1200
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: Strange Graphic Glitches

Post by Runnerbean on Thu Mar 15, 2018 8:12 pm

Thank you for the suggestion about Imgur.

This is what I'm experiencing with London Underground routes whenever I'm outside of the tunnels above ground. These glitches don't appear when underground.

This one happens to be on the Northern Line.


Runnerbean

Posts : 7
Join date : 2018-03-14

Back to top Go down

Re: Strange Graphic Glitches

Post by leezer3 on Thu Mar 15, 2018 8:20 pm

Your graphics card is not a happy bunny Sad
What you're seeing is what's known as 'artifacting'.

It's definitely not openBVE version related, or at least not specifically. Couple of simple things to try:

  • Try different driver versions.
  • Check for overheating. (Laptop or desktop?) - This is the most likely explanation, as your card is going to be working considerably harder once out of the tunnels.


What card do you actually have?

leezer3

Posts : 1200
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: Strange Graphic Glitches

Post by Runnerbean on Thu Mar 15, 2018 8:56 pm

Its a GTX 1080-TI with the latest Drivers. A beast of a graphics card so I can't see this as being the problem considering the heavy modern based PC games I play on this desktop machine without problems.

I monitor my GPU temps with MSI Afterburner and this card doesn't break a sweat with this old game so I can only assume it either doesn't like this Driver or there is a bug somewhere.

Runnerbean

Posts : 7
Join date : 2018-03-14

Back to top Go down

Re: Strange Graphic Glitches

Post by leezer3 on Thu Mar 15, 2018 9:33 pm

Dunno...

I've got a 1060 6gb here on driver version 391.01 (Windows 8.1), and I've definitely no glitches on the Northern line with any of a random selection of builds from the priors pile.

I'd play with some driver versions and see where you get.

Last report of similar glitches was here:
http://bveworldwide.forumotion.com/t1297p275-openbve-1-5-0-rc1-bugs#15594
That was an ATI card, and solved by playing around with driver versions.

leezer3

Posts : 1200
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: Strange Graphic Glitches

Post by Runnerbean on Thu Mar 15, 2018 10:40 pm

Sounds like the problem is on my end then. I'll try with some other Drivers as that's all it can be really. Thanks for your help and advice.

Runnerbean

Posts : 7
Join date : 2018-03-14

Back to top Go down

Re: Strange Graphic Glitches

Post by Quork on Fri Mar 16, 2018 8:01 am

Try a current, graphically challenging route - dunno, maybe Birmingham - X-City South? CTS routes are really great, but actually very efficient - Graymac is a master! - so they won't test the GPU that much. But it might be of interest to check it out with other routes.
avatar
Quork

Posts : 1201
Join date : 2012-05-05
Age : 27
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Re: Strange Graphic Glitches

Post by Runnerbean on Sat Mar 17, 2018 2:14 pm

Thanks Quork. I'm a new to openBVE so where's the best place to get routes and trains like the one you mention above? Any links to trusted and safe sites would be appreciated.

Runnerbean

Posts : 7
Join date : 2018-03-14

Back to top Go down

Re: Strange Graphic Glitches

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum