First I installed 1.4.0 fails then github 1.5.1.4 getting installation errors on Ubuntu 17.04

Go down

First I installed 1.4.0 fails then github 1.5.1.4 getting installation errors on Ubuntu 17.04

Post by Cool Games on Thu Jul 06, 2017 6:30 pm

I started with openbve from repository on Ubuntu 17.04
It installed but then fails to run as described here.

I then did source build with git clone github.com/leezer3/OpenBVE.git
I did these
$ make debian
$ cd installers/debian/
$ sudo dpkg -i debian.deb
got this
dpkg: error processing archive debian.deb (--install):
 trying to overwrite '/usr/lib/openbve/OpenBve.exe.config', which is also in package openbve-data 1.4.0.10+dfsg-1
 THEN:
$ sudo dpkg -i --force-all  debian.deb

got
 openbve depends on libmono-corlib4.0-cil (>= 3.2.Cool; however:
  Package libmono-corlib4.0-cil is not installed.

$ sudo apt-get install libmono-corlib4.0-cil

gets
However the following packages replace it:
  mono-reference-assemblies-4.0 mono-devel

next tried
$ sudo apt-get install mono-reference-assemblies-4.0 mono-devel

gets
mono-devel is already the newest version (4.6.2.7+dfsg-1ubuntu1).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 openbve : Depends: libmono-corlib4.0-cil (>= 3.2.Cool but it is not installable

$ sudo apt --fix-broken install
After this operation, 15.3 MB disk space will be freed.
Do you want to continue? [Y/n] 

YAY !

or not...
$ openbve
The program 'openbve' is currently not installed. You can install it by typing:
sudo apt install openbve

I can reply here after logouts and reboots for status updates.

Not a developer despite my email used for debugging

Lee T. Davy
Cool Games
avatar
Cool Games

Posts : 3
Join date : 2017-07-06
Location : Groton , MA USA

Back to top Go down

Successful install on Ubuntu Studio 17.04 with manual help

Post by Cool Games on Thu Jul 06, 2017 6:55 pm

Manually copied from source tree debian/usr all files to system and chmod +x openbve so it is starting to work...

Keep checking here for progress...
Attachments
Built from Source - Screenshot_2017-07-06_14-00-54.jpg Screen Capture - yay !You don't have permission to download attachments.(227 Kb) Downloaded 1 times
avatar
Cool Games

Posts : 3
Join date : 2017-07-06
Location : Groton , MA USA

Back to top Go down

Re: First I installed 1.4.0 fails then github 1.5.1.4 getting installation errors on Ubuntu 17.04

Post by leezer3 on Thu Jul 06, 2017 9:56 pm

Short answer is that the Debian package has been being built against Wheezy for quite a while.

Probably needs the libmono-corlib bumping to 4.5 now that Wheezy is no longer current, even though irritatingly the version bump doesn't actually break anything....
Nothing in the install is actually Linux specific per-se, the deb is just a convenient installer pinched from when it Paul Sladen was involved Smile

Will add to my list to deal with ASAP...

leezer3

Posts : 1229
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Crash in station on first successful excursion with S103 AVE in Spain.

Post by Cool Games on Thu Jul 06, 2017 11:00 pm

I got it to work as I said with manual copy of files and chmod +x

I just finished (literally) S103 in Barcelona route as I did in 2008.
Only European rail fanning.
See coolgames.net for YouTube evidence.
Attachments
Crash in Station - Screenshot_2017-07-06_17-56-14.jpg Learning OpenBve with S103 AVE in Barcelona. Controls, signals and red light.You don't have permission to download attachments.(35 Kb) Downloaded 3 times


Last edited by Cool Games on Thu Jul 06, 2017 11:05 pm; edited 1 time in total (Reason for editing : Add image and title.)
avatar
Cool Games

Posts : 3
Join date : 2017-07-06
Location : Groton , MA USA

Back to top Go down

Re: First I installed 1.4.0 fails then github 1.5.1.4 getting installation errors on Ubuntu 17.04

Post by Locomotion on Fri Jul 07, 2017 11:19 am

Ah, this looks to be the answer to the query I posted in 'Technical Questions' recently;

http://bveworldwide.forumotion.com/t1393-openbve-on-linux-mint#15322

Thanks leezer3,

loco

Locomotion

Posts : 16
Join date : 2015-05-28

Back to top Go down

Re: First I installed 1.4.0 fails then github 1.5.1.4 getting installation errors on Ubuntu 17.04

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum