openBVE 1.5.0 RC1 - BUGS

Page 15 of 15 Previous  1 ... 9 ... 13, 14, 15

Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by parker78 on Sat Jun 02, 2018 8:31 am

Hello ,

I am parker78 in version 1.5.3.3.
My problem is the same: http://bveworldwide.forumotion.com/t1351-joystick-control
apparently there is no problem, but my joystick is not recognized
Thank you

Log:

openBVE Log: 15/05/2018 17:01:11

17:01:14  Loading route file: C:\Program Files (x86)\openBVE\UserData\LegacyContent\Railway\Route\Network West Midlands 2011 preview\2006-2010\05.13 [150] Whitminster-Riverside 3car local 2006.csv
17:01:14  C:\Program Files (x86)\openBVE\UserData\LegacyContent\Railway : Railway folder found.
17:01:14  Route file format is: CSV
17:01:29  Route file loaded successfully.
17:01:29  Loading player train: C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\Cl153_openbve_2_voitures_exter
17:01:29  a0 in section #ACCELERATION is expected to be greater than zero at line 10 in file C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\Cl153_openbve_2_voitures_exter\train.dat
17:01:29  a1 in section #ACCELERATION is expected to be greater than zero at line 10 in file C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\Cl153_openbve_2_voitures_exter\train.dat
17:01:29  v1 in section #ACCELERATION is expected to be greater than zero at line 10 in file C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\Cl153_openbve_2_voitures_exter\train.dat
17:01:29  v2 in section #ACCELERATION is expected to be greater than zero at line 10 in file C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\Cl153_openbve_2_voitures_exter\train.dat
17:01:29  The #ACCELERATION section defines 8 curves, but the #HANDLE section defines 7 power notches in C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\Cl153_openbve_2_voitures_exter\train.dat
17:01:29  Loading train panel: C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\Cl153_openbve_2_voitures_exter\panel2.cfg
17:01:31  Train panel loaded sucessfully.
17:01:31  Loading train plugin: C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\Cl153_openbve_2_voitures_exter\UKSpt.dll
17:01:31  Train plugin loaded successfully.

Openbve crash:

12/03/2018 12:07:44
OpenBVE 1.5.3.1 Crash Log
Program is running on the Windows backend
Current screen resolution is: Windowed 1600px X 900px
Current routefile is: C:\Program Files (x86)\openBVE\UserData\LegacyContent\Railway\Route\Victoria Line\OpenBVE - 1967 (Manual) Walthamstow Central to Vauxhall - Copy.csv
Current train is: C:\Program Files (x86)\openBVE\UserData\LegacyContent\Train\LT1967
Current train plugin is: os_Ats1.dll
8 file(s) not found
23 error(s), 1 warning(s)
The current routefile caused the following exception:
System.IndexOutOfRangeException: L'index se trouve en dehors des limites du tableau.
   à OpenBve.MainLoop.ProcessKeyboard()
   à OpenBve.OpenBVEGame.OnRenderFrame(FrameEventArgs e)
   à OpenTK.GameWindow.RaiseRenderFrame(Double elapsed, Double& timestamp)
   à OpenTK.GameWindow.DispatchRenderFrame()
   à OpenTK.GameWindow.Run(Double updates_per_second, Double frames_per_second)
   à OpenBve.MainLoop.StartLoopEx(MainDialogResult result)
   à OpenBve.Program.Main(String[] args)   à System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
   à System.Environment.get_StackTrace()
   à OpenBve.Program.Main(String[] args)
Current program memory usage: 192,23mb
System memory free: 12753mb

parker78

Posts : 16
Join date : 2017-07-07

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 on Sat Jun 02, 2018 10:43 am

I can't see anything immediately wrong, sorry Sad
I've got two gamepads (Xbox 360, random Chinese thing), a joystick (unbranded) and a RailDriver here, all of which appear to work correctly.

What is your joystick model?

The Victoria line isn't crashing for me either.

leezer3

Posts : 1128
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by parker78 on Sat Jun 02, 2018 1:21 pm

Thank you for this quick response .
My joystick is a T.flight stick X
basic and worked fine in previous version

parker78

Posts : 16
Join date : 2017-07-07

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 on Sat Jun 02, 2018 11:21 pm

Try this, I think I've squashed it:

https://vps.bvecornwall.co.uk/OpenBVE/Builds/OpenBVE-2018-06-02.zip

leezer3

Posts : 1128
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by parker78 on Sun Jun 03, 2018 8:38 am

the joystick is still not recognized. ????

parker78

Posts : 16
Join date : 2017-07-07

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by Quork on Sun Jun 03, 2018 1:25 pm

Is it still recognised by the system itself?
avatar
Quork

Posts : 1166
Join date : 2012-05-05
Age : 26
Location : Hofheim a.T., Hessen (Hesse), European Union

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by parker78 on Sun Jun 03, 2018 3:53 pm

Hi!
by windows 7 yes. it worked well before the update

parker78

Posts : 16
Join date : 2017-07-07

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by graymac on Sun Jun 03, 2018 5:07 pm

I'd be wondering about drivers for the joystick device??
avatar
graymac

Posts : 1894
Join date : 2011-08-28
Location : Co Mayo, Eire

http://www.celtictrainsim.com

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by parker78 on Sun Jun 03, 2018 6:27 pm

Hi,
the joystick works well with other simulations. I had the same problem in July 2017:
http://bveworldwide.forumotion.com/t1351p25-joystick-control
What is strange is that I am apparently the only one with this problem.
This problem is recurring after an update

parker78

Posts : 16
Join date : 2017-07-07

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by leezer3 on Sun Jun 03, 2018 7:41 pm

I don't think the two problems are related per-se, just co-incidental.

Please try resetting the control assignments (one or two will do to test) with the build I linked above & see if that helps.
I'd also like to know whether the controls menu correctly shows the joystick movements?
Trying a button as opposed to an axis might also tell us something.

The only other thing I can think of off the top of my head is that openBVE has never handled multiple joysticks particularly well.
If more than one is connected to the PC, the numbering is somewhat arbritary, and it only polls by number.
Must try and do something about that...

leezer3

Posts : 1128
Join date : 2011-08-23

http://www.bvecornwall.co.uk

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by parker78 on Mon Jun 04, 2018 10:00 am

Oops, today I'm ashamed, it's been 30 years that I do computer science, I suddenly feel very very old.
You just had to disconnect the joystick and reconnect it on another usb port so that it reinstalls the drivers.
I thank you all for your help, I was stupidly locked in my certainties.

parker78

Posts : 16
Join date : 2017-07-07

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by graymac on Mon Jun 04, 2018 10:24 pm

graymac wrote:I'd be wondering about drivers for the joystick device??

bounce bounce bounce
Don't worry, you're not the first one to get the Homer Simpson "Genius" Award - doh!

avatar
graymac

Posts : 1894
Join date : 2011-08-28
Location : Co Mayo, Eire

http://www.celtictrainsim.com

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by parker78 on Tue Jun 05, 2018 1:21 pm

I feel less lonely now Very Happy

parker78

Posts : 16
Join date : 2017-07-07

Back to top Go down

Re: openBVE 1.5.0 RC1 - BUGS

Post by Sponsored content


Sponsored content


Back to top Go down

Page 15 of 15 Previous  1 ... 9 ... 13, 14, 15

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum